FLProg
Вход на сайт
Логин:
Пароль:
Мы в VK
Поиск
Статистика


Яндекс.Метрика
Пятница, 09.12.2016, 12:40
Приветствую Вас Гость | RSS
Главная | Регистрация | Вход

Поиск по сайту


Форум
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 41234»
Модератор форума: support, Сергей 
Форум » Основной » Спросить у знатоков » Помощь с Modbus
Помощь с Modbus
diman27
Дата: Воскресенье, 06.09.2015, 16:50 | Сообщение # 1
Сержант
Группа: Проверенные
Сообщений: 33
Награды: 0
Репутация: 0
Статус: Offline
Добрый день. Помогите с программой для отправки данных по Modbus. Не пойму, то ли usb адаптер не работает, то-ли я не правильно пишу.
Прикрепления: 6083150.flp(100Kb)
 
Max Дата: Воскресенье, 06.09.2015, 17:23 | Сообщение # 2
Гуру
Группа: Проверенные
Сообщений: 484
Награды: 14
Репутация: 4
Статус: Offline
Все же перед передачей данных, лучше всего значение ввести в виде переменной, а потом уже оперировать с ней (то бишь переменной).

Максим (VK - Максим Дунаевский)
 
diman27 Дата: Воскресенье, 06.09.2015, 17:50 | Сообщение # 3
Сержант
Группа: Проверенные
Сообщений: 33
Награды: 0
Репутация: 0
Статус: Offline
Вот так?
Прикрепления: Modbus.flp(65Kb)
 
Max Дата: Воскресенье, 06.09.2015, 17:55 | Сообщение # 4
Гуру
Группа: Проверенные
Сообщений: 484
Награды: 14
Репутация: 4
Статус: Offline
Да, можно так попробовать.

Максим (VK - Максим Дунаевский)
 
diman27 Дата: Воскресенье, 06.09.2015, 18:00 | Сообщение # 5
Сержант
Группа: Проверенные
Сообщений: 33
Награды: 0
Репутация: 0
Статус: Offline
Qmodbus такую ошибку выдает.
Прикрепления: 0046535.jpg(17Kb)
 
Max Дата: Воскресенье, 06.09.2015, 18:16 | Сообщение # 6
Гуру
Группа: Проверенные
Сообщений: 484
Награды: 14
Репутация: 4
Статус: Offline
На данный момент автор дорабатывает ModBus.
Я в своем проекте передавал данные с датчиков DS18 (14 штук) со слейва на мастер и с индикацией на дисплее мастера.
Перед передачей на каждый датчик заводил переменную... Все отлично отправлялось.


Максим (VK - Максим Дунаевский)
 
diman27 Дата: Воскресенье, 06.09.2015, 18:23 | Сообщение # 7
Сержант
Группа: Проверенные
Сообщений: 33
Награды: 0
Репутация: 0
Статус: Offline
Сможите выложить ваш проект посмотреть?
 
Max Дата: Воскресенье, 06.09.2015, 18:46 | Сообщение # 8
Гуру
Группа: Проверенные
Сообщений: 484
Награды: 14
Репутация: 4
Статус: Offline
Вот слейв. Не прикрепляется. Мой файл больше 500Kb... Порезал на половину...
Прикрепления: ModBus_1-2_SLAV.flp(280Kb)


Максим (VK - Максим Дунаевский)

Сообщение отредактировал Max - Воскресенье, 06.09.2015, 18:52
 
diman27 Дата: Воскресенье, 06.09.2015, 19:06 | Сообщение # 9
Сержант
Группа: Проверенные
Сообщений: 33
Награды: 0
Репутация: 0
Статус: Offline
Хм... Вроде все так. Видимо под win10 usb адаптер не хочет работать.
И еще вопрос. При настройке Modbus "Индекс 1" это адрес адаптера в сети, я правильно понял?
 
Max Дата: Понедельник, 07.09.2015, 16:29 | Сообщение # 10
Гуру
Группа: Проверенные
Сообщений: 484
Награды: 14
Репутация: 4
Статус: Offline
Пробовал пользоваться Qmodbus. Что то через раз работала эта программа, какая то нестабильная.... Тупо соединил две ардуинки с модбасами и все стало работать.

Максим (VK - Максим Дунаевский)
 
kulibin Дата: Пятница, 11.09.2015, 20:07 | Сообщение # 11
Рядовой
Группа: Проверенные
Сообщений: 3
Награды: 0
Репутация: 0
Статус: Offline
Проблема с подключением свистка USB to RS485. Устройство установилось как USB-SERIAL CH340(COM30). Но в Flprog, в разделе Modbus выбор COM порта у меня почему то только один COM_0. Я так понимаю это номер физического порта компьютера.
Программа QModBus тоже не может подключиться к COM 30. Подскажите есть ли решение как связать все вместе.
 
diman27 Дата: Суббота, 12.09.2015, 14:28 | Сообщение # 12
Сержант
Группа: Проверенные
Сообщений: 33
Награды: 0
Репутация: 0
Статус: Offline
У меня точно такой же свисток, на рабочем компе с win7 32 я через него подключаюсь к modbus, а QModBus его в упор не видит, может и flprog тоже, но проверить на компе с работы пока не могу.
 
RusSanya Дата: Вторник, 15.09.2015, 13:13 | Сообщение # 13
Рядовой
Группа: Проверенные
Сообщений: 11
Награды: 0
Репутация: 0
Статус: Offline
Попробовал сегодня на новой версии (1.10) поработать с ModBus. С одним слейвом и 4 регистрами стало заметно лучше (быстрее). При двух слейвах - все о-о-очень медленно, даже не дождался приема. Ждемс-с-с. Спасибо автору.
 
kulibin Дата: Вторник, 15.09.2015, 22:16 | Сообщение # 14
Рядовой
Группа: Проверенные
Сообщений: 3
Награды: 0
Репутация: 0
Статус: Offline
RusSanya, через какой преобразователь подключаетесь к слейвам?
 
RusSanya Дата: Среда, 16.09.2015, 07:34 | Сообщение # 15
Рядовой
Группа: Проверенные
Сообщений: 11
Награды: 0
Репутация: 0
Статус: Offline
Цитата kulibin ()
RusSanya, через какой преобразователь подключаетесь к слейвам?

Вот этот http://www.ebay.com/itm....c57a28e
Но это не принципиально, любой преобразователь RS232/485 подойдет.
Все-таки мобдас еще нужно серьезно дорабатывать (медленно работает).
 
Форум » Основной » Спросить у знатоков » Помощь с Modbus
Страница 1 из 41234»
Поиск:

FLProg © 2016
Яндекс.Метрика